Jump to content

P0220 P1221 Limp Mode

3.2 gt limp mode power loss headlights

  • Please log in to reply
No replies to this topic

#1 Saabretooth

Saabretooth

    Turismo

  • 184 posts
  • What car do you drive?:
    Alfa Romeo GT 3.2 V6 Novitec
  • Location:
    Singapore

Posted 12 July 2017 - 01:47 PM

Back in this forum after years of trouble free motoring.Friend of mine has got this issue of car going into limp mode with P0220 and P1221 error codes.


Headlights off. Limp mode guaranteed to come on after a while. Always after stationary, i.e. Low rpm around 700-800rpm.

In the morning or sometimes even at cold start, while driving in the car park.

BUT!!!!

Immediately gone when he switched on the headlights!and then...

Limp mode will return after 10- 20 mins even with lights on. He'll have to switch it off and on to reset the error to drive it without limp mode.

So short of replacing the entire headlight assembly, what can he do?

The throttle position sensors...etc has been cleaned and replaced and etc... and there was, the U1600 error code comes up.

A couple of workshops have tried to solve it but are not successful.

One of them suggests the throttle body (due to the P0220 and P1221 codes), while another says its the ECU due to the U1600 error (not all the time).


Any thing that makes sense that we could troubleshoot with?


Cheers!

Edited by Saabretooth, 12 July 2017 - 02:26 PM.






Also tagged with one or more of these keywords: 3.2 gt, limp mode, power loss, headlights

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users