Jump to content
Sign in to follow this  
Saabretooth

P0220 P1221 Limp Mode

Recommended Posts

Back in this forum after years of trouble free motoring.Friend of mine has got this issue of car going into limp mode with P0220 and P1221 error codes.

 

 

Headlights off. Limp mode guaranteed to come on after a while. Always after stationary, i.e. Low rpm around 700-800rpm.

 

In the morning or sometimes even at cold start, while driving in the car park.

 

BUT!!!!

 

Immediately gone when he switched on the headlights!and then...

 

Limp mode will return after 10- 20 mins even with lights on. He'll have to switch it off and on to reset the error to drive it without limp mode.

 

So short of replacing the entire headlight assembly, what can he do?

 

The throttle position sensors...etc has been cleaned and replaced and etc... and there was, the U1600 error code comes up.

 

A couple of workshops have tried to solve it but are not successful.

 

One of them suggests the throttle body (due to the P0220 and P1221 codes), while another says its the ECU due to the U1600 error (not all the time).

 

 

Any thing that makes sense that we could troubleshoot with?

 

 

Cheers!

Edited by Saabretooth

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×