Jump to content

tony-1977

Administrators
  • Content Count

    136
  • Donations

    0.00 GBP 
  • Joined

  • Last visited

  • Days Won

    2

tony-1977 last won the day on October 24 2016

tony-1977 had the most liked content!

Community Reputation

10 Good

1 Follower

About tony-1977

  • Rank
    Turismo

Converted

  • What car do you drive?
    Alfa Romeo 147 JTDm / BMW 520d SE
  • Location
    United Kingdom
  1. Have you got heater set to highest temp? ---Sent from my Samsung Galaxy S7 Edge
  2. If the temp dial does not rise, you'd be looking a new thermostat. Yours will be stuck open ---Sent from my iPhone 6 using Tapatalk
  3. Any luck with that? ---Sent from my iPhone 6 using Tapatalk
  4. Mine was just like that. Perfect above 1700ish rpm. Just nothing low down. New MAF and it was transformed. Maybe try disconnecting yours to see if any difference? ---Sent from my iPhone 6 using Tapatalk
  5. Try the MAF too. My old Passat had exactly the symptoms you describe. Changed the MAF and it transformed the car ---Sent from my iPhone 6 using Tapatalk
  6. Welcome to the forum :-) ---Sent from my iPhone 6 using Tapatalk
  7. Hello all. Just want to introduce myself to the forum. Alfa 147 (56 reg, 1.9JTDm) owner from Newcastle. Here to help out and share info with you all :-) Here's a few pics of my baby :-) ---Sent from my iPhone 6 using Tapatalk
  8. I've banned a load of spammers today and removed some threads. Will take time but getting there Sent from my iPhone using Tapatalk
×
×
  • Create New...