Jump to content
Sign in to follow this  
GTA

Selespeed: Problem Going Into Even Gears

Recommended Posts

Hi

 

I have a problem..

For a while now, my GTA Selespeed has difficulty engaging even gears.

I can hear the actuator working, the system is making the engine match revs, but the gear does not engage.

I can hear and feel the actuator trying to get the gear in twice, but then fails and gets into the next alternative odd gear. (So if it cannot reach 2nd it either goes into 1st or 3rd, if it cannot reach 4th it goes into 3rd or 5th).

 

There are no beebs, and no error messages in the system to look at.

Not so long ago, I had one potentiometer sensor replaced. Could it be that a functioning sensor was replaced with a faulty one ?

 

I have recalibrated the system a little while back (two weeks ago) and realigned the clutch when this was last happening, but it seems not to have worked.

 

So my question is:

What is preventing the system from engaging even gears ? (ie. what is controlling this)

Is there a way to test the sensors while they are outside ? As a surefire way of eliminating them as being the cause, at least

Share this post


Link to post
Share on other sites

Right, I have made it home, and armed with a multimeter, test leads and youtube I started to measure the resistance of two spare potentiometers.

I have no idea if what I am doing is correct or not, BUT:

One potentiometer ranges from about 1020 Ohms (have I got the scale right? ) going to about 2400 Ohms at 3/4 way before dropping to 2300 Ohms before going off the scale.

The other starts a 940 Ohms, going onto 2050 Ohms before dropping back onto 1500 Ohms.

 

I dont know if my leads are poor (home made) but occasionally I get strange readings ranging up to 4000 Ohms on one of them.

 

Does my experiment prove anything ?

Should I try to remove the one in the car and do the same to it ?

Edited by GTA

Share this post


Link to post
Share on other sites

Someone shoot me, cause I just made it worse.

 

Fed up with not being able to use the car, I tried to replace the sensor with one of the others.

If nothing else, i can rule that out, I though.

 

Well, so I removed the old one. (The bottom one, the one measuring the forwards / backwards movement) and I only got odd gears.

I then swapped back to the original sensor, and still only got odd gears. (Before I could occasionally get an even gear, now there was nothing at all)

Thinking I had installed them wrong, I fiddled about, and the black plastic inside lever came off.

I spent some time trying to install it right, but thinking I hadn't been successful (as I constantly only got odd gears), I decided to remove the plastic that holds both sensors and gambled on being able to install both once I had that lot off.

 

And no.

I now have no gears at all, as I cant get the up/down lever attached to its little tab.

Argh Argh Argh.

 

How the devil to I clean up my own mess now ?

Share this post


Link to post
Share on other sites
:( bummer mate I know nothing about selespeeds hopefully smaky will be along soon to help

Share this post


Link to post
Share on other sites

I am hoping he will see this thread as well :)

 

Anyway first order of the day this evening will be to bring down the laptop and check if the sensors are moving when gear are being asked for.

Then taking the plate off (with sensors attached) and move the sensors by hand to check if the movements are the same.

If the measurements are different, I am installing them wrong.

If they are the same... then I am lost.

Share this post


Link to post
Share on other sites

FIXED!

 

Here is a top tip if you should ever do this on your own: PUT THE BLOODY CAR INTO NEUTRAL FIRST!

Basically, the sensor attached to a pin that attaches to a lever that attaches to another pin which is part of the actuator.

That other pin is going to be in an in-acessible position if the car is in gear.

 

So I replaced the (what I believe to be) the faulty sensor with the better one that I have, and it seems to have done the trick. All gears working 100%. That said, I have only driven 10 kilometers yet. I also tested the "faulty" sensor on a multimeter, and its readings are fine, goes from 900 Ohms up to 2300 to then drop to 2100.

 

Maybe Smaky or someone else here can do a test on a well know working sensor and tell me what I should be getting and what the tolerances are ??

 

Anyway, Pizza time!

Edited by GTA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×